WordPress 2.0.4 in geografski položaj

Včeraj sem blog nadgradil na WordPress 2.0.4. Ob tem mi je nehal delovati Geo Plugin, ki je skrbel za prikaz na zemljevidu si.blogs (no, ni ravno nehal delovati, je pa začel javljati neko napako). Najprej sem seveda krepko zaklel, nato pa sem se lotil iskanja nadomestka. Ugotovil sem, da obstaja kar nekaj tovrstnih pripomočkov. Ker si že lep čas želim, da bi imel možnost tudi na kak priročen način prikazovati geografske položaje posamičnih zapisov, sem sklenil poiskati plugin, ki zmore tudi to. Za najboljšega se je izkazal GeoPositions, vendar je pri njem treba v zapis ročno vstaviti oznako, iz katere nastane povezava do položaja na izbranem spletnem zemljevidu, pa še s položaji, ki sem jih določil z Geo Pluginom, ne zna nič početi.

Ker sem našel tudi dva plugina, ki znata položaje zapisov prikazovati na podlagi Geo Pluginovih oznak, sem šel še enkrat pogledat, če morebiti obstaja kaka popravljena različica slednjega (kajpada sem to storil tudi takoj, ko so se začele težave, ampak sem takrat zaključil, da ne). No, k sreči se je izkazalo, da res obstaja (in da sem prvič pogledal slabo), tako da sem si jo namestil, poleg nje pa še Plug ‘n’ Play Google Map (drugi tovrsti plugin, Geo Mashup, je pri nastavitvah izpljunil sporočilo o napaki). Rezultat je tale zemljevid (ki je na voljo tudi med povezavami na desni).

Preden sem Plug ‘n’ Play Google Map lahko uporabil, sem ga moral malce popraviti. Razlog je bil, da je prikazoval vse zapise, ki imajo določen geografski položaj. Teh je pri meni večina, so pa trenutno le iz petih različnih krajev, tako da so se v glavnem izrisali eden čez drugega, kar je bilo čisto nekoristno (ker je bilo itak možno klikniti na le enega v vsakem kraju), je pa izrisovanje naredilo precej počasno. Zdaj sem plugin predelal tako, da izriše samo zadnji zapis iz vsakega kraja.

5 odzivov na “WordPress 2.0.4 in geografski položaj

  1. Hi, I have a problem installing the geo-plugin in my WP 2.0.4 Maybe the above post explains what to do, but unfortunately I am not able to read your language (im Dutch). Can you maybe translate to english?

  2. The post says that I had a problem with Geo Plugin in WordPress 2.0.4, which I solved by installing the latest version of the plugin (1.9.1 instead of the problematic 1.9). My problem was an error message that appeared upon publishing a post. Hope this helps.

  3. Thanks, but im afraid it doesnt help me. I tried to install the 1.9.1 version, but my wp doesnt seem to recognize the plugin (in admin/plugins geo doesnt show up). Any ideas?

  4. Sorry, no. I’ve never had a problem like that and I don’t consider myself an expert on WordPress.

Dodaj odgovor

Vaš e-naslov ne bo objavljen. * označuje zahtevana polja